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Course Overview
What You Will Learn
In this module, you will learn how to:

 n Use this course guide
 n Use the course files to complete the exercises

 

Course Overview MadCap Flare Introductory Training Guide
created with MadCap Flare

9

d
o

n
o
t

c
o
p
y



Course Overview MadCap Flare Introductory Training Guide
created with MadCap Flare

10

Course Overview MadCap Flare Introductory Training Guide
created with MadCap Flare

10

Welcome
Welcome to MadCap Software’s authorized Flare Introductory training course. This 
course will explain how you can use Flare to create:

 n MadCap HTML5 targets
 n Adobe PDF documents

Audience
This course was designed for new Flare users. 

Course Overview
This course uses a combination of feature overviews and demonstrations to introduce 
the core features of Flare. By the end of the course, you will have the skills you need to 
get started on your first Flare project.

Course Guide
The course guide is divided into the following modules:

 n Getting Started
 n Importing Content
 n Adding Content
 n Linking Content

 n Designing Content
 n Single Sourcing Content
 n Topic Reviews
 n Building Targets

Conventions
The steps in each module have an area to the right that contains details that only apply 
to our course project. We created the training manual this way so that you could follow 
the steps later while completing your own project. During the course, you should read 
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each step in the left column and then look in the right column to see if there are any 
additional class-related instructions for that step. 

Each module ends with a "Learning More" section that references the Flare help system 
and mentions more advanced topics that are covered in other classes. We encourage 
you to use the help after the course because the help is the most comprehensive and 
up-to-date source of information about how to use Flare. We will show you how to 
access the online help for Flare in the next module.

This guide uses the following icons:

Icon Name Description

Help Help topics that can provide you with more detail. 

Note Additional information about a subject. 

Tip Best practices or shortcuts.

Preparing Your Computer for the Course
You will need to install some course files and Flare to complete this course. 

To install the course files

 1. Open your browser and enter the following URL.
http://training.madcapsoftware.com/FlareIntroTraining.zip

 2. When prompted to download the file, click Save.

 3. Create a folder in your C: drive named Flare Intro Training.

 4. Save the zip file to the c:\flare intro training folder.

NOTE    You will want to save this zip file in case you want to complete the 
exercises again in the future.

 5. Right-click the downloaded zip file and select Extract All.
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 6. Click Extract.
You should now have a folder named Flare Intro Training with two folders inside 
it: Files and Cities.

To install Flare

The course setup files do not include a copy of Flare. You will need to either purchase a 
licensed copy of Flare or install a trial version on your computer to complete this 
course.

NOTE    If you complete this course using a trial version of Flare, your output will be 
scrambled in the preview and output. 

 1. Make sure your computer has the following software installed on it. 

 n Microsoft Windows 10 or later
 n Microsoft .NET Framework version 4.8 or later
 n Ghostscript - https://www.madcapsoftware.com/downloads/ghostscript64.aspx

Ghostscript is a free application that Flare uses to handle PDF and EPS files.

 2. Install Flare from the MadCap Software website or your installation CD.

 3. Open Flare and select Help > Check for Updates. Install any available updates. 

Recommended Browser

Please install Microsoft Edge to use during this course. Feel free to install any additional 
browsers for testing, if needed.
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Getting Started with Flare
What You Will Learn
In this module, you will learn how to:

 n Navigate the Flare user interface
 n Use Flare’s online help system
 n Create a project
 n Open a project
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What Is Flare?
Flare has numerous features which can be used to add, link, design, and single source 
content to create as many outputs (called "targets") as you need. In this class, we will 
focus on "the basics" of using the boldfaced features in the table below. In the 
Intermediate and Advanced classes, we cover all of these features (and others) in much 
more detail.

Task Supporting Flare Feature

Adding content Projects 

Topics 

Tables

Images 

Videos

Importing content Doc-to-Help project imports

RoboHelp projects imports

HTML Help project imports

DITA imports

HTML imports

Markdown imports

Excel imports

Word imports

FrameMaker imports

Linking and layering content Hyperlinks

Cross references

Popup links

Bookmark links
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Task Supporting Flare Feature

Drop-down links, expanding links, and toggler links

Related Topics, Keyword, and Concept links

Relationship Table links

Table of contents

Index

MadCap Search, Google Search, and Elasticsearch

Glossary

Designing content Responsive design 

Stylesheets

Responsive layouts

Table stylesheets

Template pages

Proxies

Page layouts

Skins and component skins

Single sourcing content Condition tags

Variables 

Date/Time and system variables

Snippets

Snippet conditions

Snippet variables

Project links

External resource links

Micro content
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Task Supporting Flare Feature

Sending topics for review Track changes

Annotations

Topic reviews

Building targets HTML5

Clean XHTML

WebHelp and WebHelp Plus

HTML Help and Eclipse Help

PDF documents

Word documents

DITA documents

EPUB and MOBI files

Batch targets

Publishing destinations

Managing projects Source control

Sharepoint integration

Context-sensitive help

Meta tags 

File tags

Analysis reports

Project reports

Getting Around in Flare
Flare's UI is divided into five areas: left pane, editing pane, right pane, ribbon, and toolbars. 
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Left Pane
The most important windows in the left pane are the Content Explorer and Project 
Organizer. They are arranged in an accordion to save space. 

 

Content Explorer

The Content Explorer is used to manage 
topics, images, template pages, page 
layouts, snippets, style sheets, and table 
stylesheets. You can organize your content 
using folders. 

All content except topics appears under the 
Resources folder by default.

 

Project Organizer

The Project Organizer groups the project-
level features into folders. For instance, 
Conditional Text, Glossaries, and Variables. 
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Other windows that may appear in the left pane  include: 

Window How It’s Used

Backups View a list of backups and restore one if needed.

Contributions Review and approve new topic from contributors.

External Resources Import content that is stored outside your project, 
such as an image on a network drive.

Instant Messages View and send instant messages.

Flare Online Log in to Flare Online, bind projects to Flare Online, 
and import projects from Flare Online.

SharePoint Explorer Import content from SharePoint.

Source Control Explorer Perform source control actions, including checking 
files in and out.

Topic Reviews Review and approve topic annotations and changes.

TIP   If you don’t see the Project Organizer or Content Explorer, select View > 
Project Organizer or View > Content Explorer. 

Editing Pane
The editing pane appears in the middle of the Flare main window. You can use it  to 
change topics, TOCs, and stylesheets. Each type of file has its own editor such as the 
XML Editor for topics, the TOC Editor for the TOC, and the Stylesheet Editor for the 
stylesheets. 

You can open multiple windows in the editing pane. Each window appears as a tab at 
the top of the editing pane. You can even click and drag the tabs to rearrange them. In 
the example above, there are two windows open: the North America topic and the Start 
Page.
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Start Page

On the Start Page, you can open an existing project, create a new project, open Flare’s 
help system, visit the Flare Help Community, and view news and updates from MadCap 
Software. Make sure you visit the Flare Help Community regularly to stay in touch with 
the Flare user community.
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TIP   If you don’t see the Start Page, select View > Start Page. 

Right Pane
The following windows open by default in the right pane.

Window How It’s Used

Attributes View and change the attributes of selected content.

Concepts Insert Concept (See Also) entries into topics.

Find and Replace in Files Find and replace text in files.

Find Elements Find HTML tags, Flare-specific content, or style classes.

Footnotes View the footnotes that have been added to the option topic.

Formatting Review and modify style settings.

Glossary Terms Add glossary terms and definitions.

Hyphenation Add and modify hyphenation rules for words.

Index  Insert index keywords into topics.
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Window How It’s Used

Local Formatting Override style settings for specific content in a topic.

Responsive Layout Create and insert responsive layouts.

Spell Check Check your project for spelling errors.

Styles View and apply styles to content.

TIP   You can move any of the windows in Flare to your preferred location. 

Ribbon
The ribbons menus include:

 n Home
 n Insert
 n View
 n Project
 n Analysis
 n Review

 n Tools
 n Source Control (if your project is bound to source control)
 n Table
 n eLearning
 n Window
 n Help

Finding a File or Command
You can use the Quick Launch bar in the upper right of the Flare window to find a 
command or file. Click inside the Quick Launch bar or press Ctrl-Q and type the name of 
the command or file.
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Closing a window 

To close a window, click in the title bar of the window.

Flare’s Help System
Flare has an extensive help system to answer your questions as you explore new 
features. By default, the help opens from the web in your default browser. If you can't 
connect to the web or need to view the help offline, you can set Flare to use a local 
version of the help system in the Options dialog box on the General tab.

TIP   The Flare help system Flare includes several video tutorials that you may want 
to complete after this class as a refresher.

What Is a Project?
In Flare, a project is a container for all of the files and settings that will be used to create 
your target(s). A project includes: 

 n Content that you create, insert, and import into Flare
 n Project settings you specify to control the behavior of online targets
 n Targets that you build

Project Files
When you create a project, you are prompted to specify a project name and a folder 
where you want to store the project files. After creating a project, you can look at the 
project folder in Windows Explorer.
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Notice that the project folder 
contains a .flprj file. This file is 
called the project file. 

Double-clicking the project file will 
open the project in Flare.

 

Folder Name What’s in this Folder?

Analyzer A SQL Compact database that contains information for 
Flare's Analyzer reports, such as broken links.

Content All of your content, including topics, images, videos, 
sounds, and style sheets. Any folders that you create in the 
Content Explorer will also appear in the "Content" folder.

Project Project files, including browse sequences, conditional tag 
sets, publishing destinations, glossaries, skins, targets, 
tables of contents, and variables.

Output All built targets for the project, such as HTML5 or print 
documentation.

Creating a Project
Creating a project is the first thing you do when you start to use Flare. There are 
numerous ways that you can create a project:

 n Create a project based on a template

 n Import a non-Flare project, such as a Doc-to-Help, RoboHelp, or HTML Help 
project

 n Import Confluence pages

 n Import a DITA document set

 n Import an Excel workbook
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 n Import a FrameMaker document

 n Import an HTML file or files

 n Import Markdown files

 n Import a Word document

How Many Projects Do You Need?
You can build multiple targets from a single project. If you have different projects that 
share a large amount of content or are only slightly different in content and structure, 
you should probably combine them into a single project.

Opening a Project
Let’s open an existing Flare project. Our "Cities" project is in the Flare Introductory 
Training folder. 

To open a project: Class project notes

1 Select File > Open.

The Open dialog box appears.

 

 

2 Locate and select the Flare project.

Flare project files have a .flprj extension.

 

Select c:\flare introductory training\ cities\cities.flprj.

3 Click Open.
The project opens in Flare.
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Learning More

Flare Help
The Flare help contains numerous useful topics about projects:

Interface and Files > Primary Window Panes

 n Content Explorer
 n Project Organizer 

 

Flare Intermediate Training
In addition to the topics covered in this class, the Flare Intermediate class 
includes the following topics:

 n Sharing files between Flare projects
 n Binding a project to source control
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Adding Content
What You Will Learn
In this module, you will learn how to:

 n Create a topic
 n Change a topic
 n Create a bulleted list
 n Create a numbered list
 n Insert an image  into a topic
 n Insert a video into a topic
 n Add a table 
 n Preview a topic
 n Find and replace text
 n Spell check your topics
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About Topics
A "topic" is a chunk of information about a subject. For example, in this guide every 
heading 1 and heading 2, like the "About Topics" heading above, starts a new topic. 
When users view an online target, they only see one topic at a time. 

A topic should answer a specific question like “how do I do this?” or “when should I do 
this?” or “how can I fix this?”. The length of your topics will vary, but they should be brief, 
focused, and easy to scan. If you’re not sure that a topic answers a specific question, 
you may not need the topic.

Images and Videos
In addition to text, topics can contain images and videos. You can create and modify 
your images and videos in any application, including MadCap Capture and MadCap 
Mimic.

MadCap Capture

MadCap Capture is a free screen capture and image editing program that includes 
several useful features:

 n Profiles – You can use profiles to apply settings (such as width and 
height) automatically when they are captured.

 n Layers – You can add text callout layers that are easy to update.
 n Single-source images – You can specify different images resolutions for 

different outputs. For example, you can specify a resolution of 72 DPI for 
online targets and 300 DPI for print targets. 

 n Palettes – You can save objects such as  shapes to reuse in images.

MadCap Mimic

MadCap Mimic is a video-capture and editing program that uses advanced 
compression techniques to create much smaller videos than other video editing 
programs. All of the videos in Flare’s online help were created with MadCap Mimic.
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Creating a Topic
Let’s create a new topic. 

To create a topic: Class project notes

1 Select File > New.

The Add File dialog appears.

 

 

2 In the File Type section, select Topic.

 

 

3 Select a Source. Select New from template and select the 
NewTopic.htm template.
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4 Select a Folder.

 
Click  and select the North America folder.

 

5 In the File Name field, delete the name “NewTopic” and type a new name 
for the topic.

 

Type San Francisco.

6 Click Add.

The topic is added to the Content Explorer and opens as a new tab in the 
XML Editor. 

 

 

7 Select Save All.  

Changing a Topic
Let’s add content to our new topic. 

To change a topic: Class project notes

1 Open a topic.

 

Open the San Francisco topic in the North America 
folder.

 

2 Type your content.

 

Replace the default topic text with:

 

San Francisco

San Francisco is a hilly city surrounded by the Pacific 
Ocean and San Francisco Bay. 

San Francisco is known for its year-round fog, iconic 
Golden Gate Bridge, cable cars, and colorful Victorian 
houses. 
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3 Select Save All.  

XML Editor Toolbar
Below is a summary of the XML Editor toolbar icons.

Top toolbar

Icon Name Description

Preview

 

Opens a new window with the current topic so you can see how the topic will appear to 
your users. The preview can be used to test conditional tags. 

Select condition tags for 
viewing

Opens the Conditional Text dialog box, which lets you select condition tags to hide 
content in the XML Editor or when sending a topic for review.

Layout Toggles between the Web, Tablet, Mobile, and Print layout views in the XML Editor. 

Medium Toggles between stylesheet mediums (alternative set of styles for different outputs) for 
viewing the topic in the XML Editor. 

Page Layout Toggles between page layouts and pages when the Layout is set to Print.

Insert a Hyperlink Opens the Insert Hyperlinks dialog box, which lets you create a hyperlink to other 
content.

Insert a Cross Reference Opens the Insert Cross Reference dialog box, which lets you insert a cross reference to 
another topic. 

Insert an Image Opens the Insert Image dialog box, which lets you insert an image. 

Insert a Snippet Opens the Insert Snippet Link dialog box, which lets you insert a snippet.

Insert a Variable Opens the Variables dialog box, which lets you insert a variable.

Quick Character Inserts a quick character, such as a copyright symbol, into a topic. You can click the 
arrow to select a character to insert.

Index Entry Mode Toggles between typing content and typing index markers.
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Icon Name Description

Concept Entry Mode Toggles between typing content and typing concept markers.

Show/Hide Space Shows/Hides paragraph and space markers. 

Show Tags Provides display options for the XML Editor, including showing/hiding tags, bookmark 
names, variable names, and index and concept markers. 

Expand All Collapsed 
Tags

Expands all collapsed tags.

Collapse All Headings Collapses all content into the highest heading leve

Open Text Editor Opens the topic in the Text Editor, where you can view and modify the XHTML code.

Bottom toolbar

Icon Name Description

Smaller Font Reduces the font scaling by 10%.

Reset Font Scaling Resets the font scaling to 100%.

Larger Font Increases the font scaling by 10%.

Set Font Scaling Displays a list of common font scaling settings, like 200%.

Show/Hide Condition 
Tags

Shows/Hides condition tag highlighting in the XML Editor, block bar, and span bar.

Show/Hide Blocks Shows/Hides the block bar on the left side of the XML Editor.

Show/Hide Spans Shows/Hides the span bar at the top of the XML Editor.

Show/Hide Indicators Shows/Hides the collapsed content arrow in the block bar.

Show/Hide Horizontal 
Ruler

Shows/Hides the horizontal ruler at the top of the XML Editor. Right-click the ruler to 
change the measurement units.
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Icon Name Description

Show/Hide Vertical Ruler Shows/Hides the vertical ruler on the left of the XML Editor. 

Show/Hide Layout 
Resizer 

Shows/Hides the layout resizer bar at the top of the XML Editor.

Advanced XML Editor Functionality
You don’t have to know XHTML to use Flare. However, the XML Editor has some useful 
features you can use if you learn the basics of XHTML tags.  

Why does the cursor appear as a left or right bracket in the XML Editor? 

When you move the cursor in the XML Editor, it changes between an I-beam, a left 
bracket, and a right bracket cursor. The left and right brackets indicate whether the 
insertion point is inside or outside a set of XHTML tags without opening the Text Editor. 

For instance, say we want to add text after the word “Properties” in the following 
example. 

The word “Properties” is tagged as bold text. There is a closing </b> tag between the 
word “Properties” and the period at the end of the sentence. For example, the code 
would look like:

If we click between Properties and te period at the end of the sentence, we see the left 
bracket cursor, indicating that the new text we type will also be bold.
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If we press the right arrow on the keyboard, we see the normal I-beam cursor, indicating 
that the cursor is now outside the </b> tag. This cursor indicates that the newly typed 
text will not be bold. 

What’s the best way to view the XML tagging? 

To view the XML tags, click the Text Editor tab. By default, the Text Editor and XML 
Editor tabs are at the bottom of the XML Editor.

What are the vertical and horizontal bars that I see around my topic?

The XML Editor provides structure bars above and to the left of the content area. These 
bars provide information about your content without having to view all of the XHTML 
tags.  

There are two types of structure bars: tag block bars and span bars.

Tag Block Bars are displayed to the left of the content area. They show the different 
XHTML tags for your blocks of content, such as "p" for paragraph.

Span Bars are displayed at the top of the content area. They show any span tags 
contained in the selected block of content. 
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Can I collapse content blocks to make topics easier to edit?

You can right-click a heading, table, ol, ul, or div tag and select Collapse to collapse the 
content. If you collapse a heading, all of the content to the next heading of the same 
level will collapse. If you collapse a table, ol, ul, or div, the content inside the tag will 
collapse.

Using the Block and Span Bars
You can use the block and span bars to select and move a chunk of similarly-tagged 
content.

To use the span and block bars: Class project notes

1 Open a topic.

 

Open the San Francisco topic in the North America 
folder.

2 Show  blocks or spans.
Show blocks and spans.

3 Click a span or block. Select the  block to the left of the third paragraph.
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4 Drag the selected span or bar to a new location.

 

Drag the block before the second sentence. When the 
arrow appears, release the mouse button.

Creating a Bulleted List
Let’s open a topic and create a bulleted list. 

In Flare, there is one list button that creates both numbered and bulleted lists. 

To create a bulleted list: Class project notes

1 Open a topic.

 

Open the Mexico City topic in the North America 
folder.

2 Position your cursor where you want to add the bulleted list or highlight 
the content you want to change to a bulleted list.

 

Highlight the list of boroughs.

 

3 In the Home ribbon, click the right arrow of the  list button.

 

 

4 Select the Bullet List type.

NOTE  If you select the circle or square list type, Flare will use 
inline formatting to format the list. You can specify a circle 
or square bullet type using styles. We will discuss 
stylesheets later in class.

 

Creating a Numbered List
Let’s open another topic and create a numbered list. 
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To create a numbered list: Class project notes

1 Open a topic. Open the Lima topic in the South America folder.

 

2 Select the paragraphs that you want to make a numbered list. Select the list of cities.

 

3 Click the right arrow of the  list icon in the Home ribbon.

 

 

4 Select Numbered List.  

NOTE    If you select the lower-alpha, upper-alpha, lower-roman, or upper-roman list 
type, Flare will use inline formatting to format the list. If you want to use any 
of these numbering options, you just need to setup your stylesheet to use it. 
We will discuss stylesheets later in class.

Inserting an Image
You can add the following types of images to a topic:

Raster formats

 n .bmp
 n .gif
 n .hdp
 n .jpg

   

 n .png 
 n .tif

Vector formats

 n .emf
 n .eps and .ps
 n .exps
 n .svg

 

 n .wdp
 n .wmf
 n .xaml
 n .xps

Vector images can be resized without losing their quality, and they are often used for 
schematics, architectural diagrams, and images that may be used at very different 
sizes. Raster images work well for photographs, and they are much more common on 
the web and better supported by older web browsers.
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NOTE    If you use a vector format, you can automatically convert it to a .gif, .jpg, or 
.png when you create an online target. You can also copy and paste an 
image into a topic. When you paste the image, Flare will prompt you to 
name the new image.

Let’s add an image to a topic. 

To insert an image: Class project notes

1 Open a topic.

 

Open the San Francisco topic in the North America 
folder.

 

2 In the XML Editor, place your insertion point cursor where you want to 
insert the image.

 

Add a blank line after the heading in the topic.

 

3 Click   in the XML Editor toolbar.
—OR—
Select Insert > Image. 

The Insert Image dialog box appears.
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4 For Select File, select an image in the project.
—OR—
Click   and select an image file.

TIP   You can pin your most commonly-used images to the top of 
the list. Just hover over the image's name in the Recently 
Used Images list and click .

Click  and select c:\flare intro 
training\files\san_francisco.png.

5 In the Alternate Text field, type a description of the image. 

Alternate text is recommended by accessibility guidelines such as the 
US Government’s Section 508 and the W3C’s Web Content Accessibility 
Guidelines (WCAG).

 

Type Golden Gate Bridge.

6 Click OK.  
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7 When you receive the notification that the file has been copied to your 
current project, click OK.

The image is copied to the Resources\Images folder and appears in 
your topic. 

 

TIP   You can also copy and paste an image into a topic. When you paste the image, 
Flare will prompt you to name the new image.

Inserting a Video
You can add the following types of multimedia files to a topic:

 n .asf
 n .asx
 n .au
 n .avi
 n .m4v
 n .mid

 n .midi
 n .mp3
 n .mp4
 n .mpa
 n .mpe
 n .mpeg

 n .mpg
 n .ogg
 n .ogv
 n .opus
 n .qt
 n .swf

 n .u3d
 n .wav
 n .webm
 n .wma
 n .wmv
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Let’s add a video to a topic.

To insert a video: Class project notes

1 Open a topic.

 

Open the Santiago topic in the South America folder.

 

2 In the XML Editor, place your insertion point cursor where you want to 
insert the movie.

 

Position the cursor on the blank line after the 
heading.

 

3 Select Insert > Multimedia.

The Insert Multimedia dialog box appears.

 

 

4 For Select File, select a multimedia file in the project.
—OR—
Click  and select a file.

Click  and select c:\flare intro 
training\files\santiago.mp4.

5 In the Alternate Text field, type a description of the video. Type Santiago at sunset.
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Alternate text is recommended by accessibility guidelines such as the 
US Government’s Section 508 and the W3C’s Web Content Accessibility 
Guidelines (WCAG). 

 

6 Click OK.

 

 

7 When you receive the notification that the file has been copied to your 
current project, click OK.

The video is copied to the Resources\Multimedia folder and appears in 
the topic as a gray box.

 

Adding a Table
Adding a table to a topic in Flare is very similar to adding a table to a document in 
FrameMaker or Word. 

Let’s add a table with three columns and five rows. 

To add a table: Class project notes

1 Open a topic.

 

Open the Toronto topic in the North America  folder.

 

2 Position the cursor where you want to add the table.

 

Position your cursor the bottom of the topic.

 

3 Select Table > Insert > Table. 

The Insert Table dialog box appears.
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4 Type or select a Number of columns.

 

Select 3.

5 Type or select a Number of rows.

 

Select 5.

6 Type or select a Number of header rows.

 

Select 1.

7 Type or select a Number of footer rows.

 

Select 0.

8 If needed, type a Table caption and select a caption location.
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9 Select a column width.

 n AutoFit to contents – each column’s width is based on the 
amount of content it contains.

 n AutoFit to window – the columns are equally-sized to fit the size 
of the window.

 n Fixed column width – each column is set to a specified width.

 

Select AutoFit to window.

10 Click OK.

 

 

11
 

Add content to the table. Move the list of languages and # of speakers content 
into the table.

NOTE    You can select Table > Enable Gridlines to add dotted lines around your 
table's rows and columns. 

Previewing a Topic 
Let’s preview a topic to see how it will look to the user. 

To preview a topic: Class project notes

1 Open a topic.

 

Open the Lima topic in the South America folder.

2 Click  in the XML Editor toolbar. 

The topic appears in the Preview window.

 

 

3 When you are finished previewing the topic, close the preview window.  
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TIP   You can leave the preview window open if you want to 
preview your changes while you work. 

Finding and Replacing Text
You can use Find and Replace to find and replace text in topics, snippets, page layouts, 
template pages, stylesheets, glossaries, and tables of contents. 

Let's change "Columbia" to "Colombia" in the Bogotá topic.

To find and replace text: Class project notes

1 Open a topic.

 

Open the Bogotá topic in the South America folder.

 

2 Select Home > Find and Replace in Files.
—OR—
Press Ctrl+Shift+F.

The Find and Replace dialog box appears.

 

 

3 In the Find field, type the text that you want to find.

 

Type Columbia. 

4 In the Replace with field, type the text that will replace the found text.

 

 

Type Colombia. 

5 Select a Find in option. 

 

Select (current document).

6 Select Match case if you want your search to be case sensitive. 

 

Select Match case.

7 Click Replace All.  
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NOTE    You can press Ctrl+F to open the quick find or Ctrl+H to open the quick 
replace. The quick find and quick replace will find and replace only in the 
current topic.

Spell Checking a Topic
You can spell check your topics while typing or by using the spell checker. As you type, 
Flare will underline unrecognized words with a jagged red line. 

Let’s look at the spell check while typing feature first.

To correct a misspelled word: Class project notes

1 Open a topic.

 

Open the Rio topic in the South America folder.

 

2 Right-click a misspelled word.

If you don’t see any red underlined words, select Tools > Spell Check 
While Typing.

 

 

Right-click populus in the first paragraph.

 

3 Do one of the following:

 n Select an alternative spelling.
 n Select Ignore All to ignore the spelling suggestion.
 n Select Add to Dictionary to add the word to the dictionary so that 

future occurrences are not flagged as misspellings.

Select populous.

Spell Checking Your Project
You can spell check the current topic, all open topics, all topics in the same folder as the 
current one, or all topics in the project. For each unknown or misspelled word, you can 
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select an alternative spelling, ignore the spelling warning, and add the word to the 
dictionary so that future occurrences are not flagged as possible misspellings. 

In our project, we will find several words that are not part of the standard dictionary 
(such as non-English words).

To spell check a project: Class project notes

1 Select Tools > Spell Check Window.
—OR—
Press F7. 

The Spell Check window appears.

 

 

2 Select what you want to Spell Check: 

 n Current document — Flare checks the spelling in the current topic. 
 n Documents in same folder — Flare checks the spelling in all topics 

in the same folder as the current topic.
 n Content folder — Flare checks the spelling in all of the files in the 

Content Explorer. 
 n Pick a Folder— Flare checks the spelling in files in a selected 

folder.
 n Whole project — Flare checks the spelling in every file in the 

project. 

 

Select Whole project.

3 When Flare finds a questionable word, a list of suggested spellings is 
displayed at the bottom of the Spell Check window.

 

 

4 To change the spelling, select a suggestion and click Change. If you are 
spell checking more than the current topic, you can click Change All Files 
to change the spelling in all of the files.

If you want to keep the word as it is, click one of the following buttons: 
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 n Skip — Flare ignores the spelling of the word and moves to the 
next misspelled word. 

 n Add to Dictionary — Flare adds the word to the project or global 
dictionary and moves to the next misspelled word. 

 n Ignore — Flare ignores the spelling of the word in this file. 
 n Ignore All — Flare ignores the spelling of the word in every file.

Closing All Windows
If you have too many windows open in the editing pane, you can close them using the 
Close All Documents or Close All Documents Except This One command.

Adding Content MadCap Flare Introductory Training Guide
created with MadCap Flare

48

d
o

n
o
t

c
o
p
y



Adding Content MadCap Flare Introductory Training Guide
created with MadCap Flare

49

Adding Content MadCap Flare Introductory Training Guide
created with MadCap Flare

49

Learning More

Flare Help
The Flare help contains numerous useful topics about adding content:

Step 2: Adding Content and Features

 n Topics 
 n Images 
 n Multimedia 
 n Tables 

 

Flare Intermediate Training
In addition to the topics covered in this class, the Flare Intermediate class 
includes the following topics:

 n Best practices for organizing content
 n Using templates
 n Changing XML Editor settings
 n Renaming topics
 n Advanced options for bulleted and numbered lists
 n Automatically formatting code snippets
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Importing Content
What You Will Learn
In this module, you will learn how to import content into Flare.
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About Importing
Importing content is a quick way to add text and images to your project. Flare can 
import .htm, .html, .xhtm, .xml, or .xhtml files, .dita files, .md files, Excel worksheets, 
Word documents, and FrameMaker documents. Flare converts imported files to .xhtml 
files. 

After you import content into Flare, you usually modify it in Flare rather than in the 
original document. However, you can also modify files in another HTML/XML editor, 
Excel, Word, or FrameMaker and reimport it.

TIP   Any images used in the imported file are also imported and placed in the 
Resources\Images folder in the Content Explorer.

Importing a Word Document
Importing a Word document is a good way to add content from subject-matter experts. 
When you import a Word document, you can split it into multiple topics based on the 
heading styles used in the document. The document’s formatting is also converted, 
along with any index entries, hyperlinks, and cross references.

NOTE    Flare requires Microsoft Word 2007 or later to import .docx Word 
documents.

Re-importing a Word Document
Flare stores your import settings in a MS Word Import file. You can use your import 
settings to re-import the Word document or to import similar Word documents. If you 
want to continue editing your content in Word rather than in Flare, you can have Flare 
automatically re-import the Word document(s) when you build a target.
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MS Word import files are stored in the Imports folder in the Project Organizer. Word 
documents are imported to the Content Explorer into a folder matching the name of the 
MS Word Import file. 

The re-import feature works well for policies and procedures guides that are written by 
multiple people. Content owners can write their content in Word, save it to a server, and 
notify the P&P author about the change. The P&P author can then re-import the 
document(s) into the policies and procedures Flare project or configure their import file 
to automatically re-import the file(s) when they build a target.

TIP   If you plan to use the import feature in Flare, you should create a template in 
Word and teach your content providers to use it consistently to avoid 
reformatting the imported content after it is in Flare.

Let’s import a Microsoft Word document. First, we will create a new MS Word Import 
file. Then, we’ll import the Word file into Flare. 
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To import a Word document: Class project notes

1 Select File > New.

The Add File dialog box appears.

 

 

2 In the File Type section, select MS Word Import File.

 

 

3 Select a Source. 

 

Select New from template and select the 
MyWordImport template.

 

4 Type a File Name.

 

Type Europe.

 

5 Click Add.

The Import Editor appears.
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6 Click the General tab.

 

 

7 In the Import to folder textbox, type or select a folder for the imported 
topics. 

 

 

8 Click Add File.

The Open dialog box appears.

 

 

9 Select a Word document and click Open.

 

Select c:\flare intro training\files\Europe.doc.

 

10 Click the Styles tab.  
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11 If you want to create new topics based on a Word heading style, check 
the checkbox in the style's Start new topic on column.

 

Check the Start new topic on checkbox for

the Heading 1 style.

12 Click the Advanced Options tab.

 

 

 

13 If you want to create a new stylesheet based on the formatting in the 
imported document(s), select Create new stylesheet.

 

Select Create new stylesheet.

14 Select how you want to import inline formatting. 

 

Select Keep inline formatting. 

15 If you want to convert the first row in each table to a header row (and 
format it, if needed), select Set first row of each table as header row.

 

Enable  the Set first row of each table as header row.

Importing Content MadCap Flare Introductory Training Guide
created with MadCap Flare

56

d
o

n
o
t

c
o
p
y



Importing Content MadCap Flare Introductory Training Guide
created with MadCap Flare

57

Importing Content MadCap Flare Introductory Training Guide
created with MadCap Flare

57

16 Select how you want to import table styles. 

 

Select Convert table styles to Flare table styles. 

17 Select whether you want to preserve or ignore page breaks. 

 

Select Ignore page breaks. 

18 Select Link Generated Files to Source Files if you want to modify the 
imported Word document(s) in Word rather than in Flare.

 

Do not select the link option. 

19 Select Auto-reimport before ‘Generate Output’ if you want to 
automatically re-import the Word document(s) when you build a target.

 

Do not select the auto-reimport option.

20 Click Import in the Import Editor toolbar.

The Accept Imported Documents dialog box appears.

 

 

21 When prompted to save the changes to the import file, click Yes.

 

 

22 Review the converted document and click Accept.

The Word document is converted to XHTML and imported into your 
project.
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Learning More

Flare Help
The Flare help contains numerous useful topics about importing content:

Step 1: Starting Projects > Import > Importing Other Applications and Files

 n Converting Author-it Files
 n Importing Confluence
 n Importing Excel 
 n Importing FrameMaker
 n Importing HTML
 n Importing Word

 

Flare Intermediate Training
In addition to the topics covered in this class, the Flare Intermediate class 
includes the following topics:

 n Best practices for importing files
 n Advanced options for importing files
 n Sharing files between Flare projects
 n Importing FrameMaker files
 n Importing external resources
 n Importing files from SharePoint
 n Importing RoboHelp and Doc-to-Help projects
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Linking Content
What You Will Learn
In this module, you will learn how to:

 n Create a TOC book and page
 n Re-arrange the items in a table of contents
 n Create a cross reference
 n Create a hyperlink 
 n Create a drop-down link
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About Links
You can organize your topics using a table of contents (TOC). Within topics, you can 
add cross references, hyperlinks and "show/hide" links such as drop-downs.

Table of Contents (TOC)
The TOC provides a structured list of links to topics or, if needed, documents or 
websites. In an online target, it becomes a menu that can be positioned at the top or on 
the side of the screen. In a print target, it appears as a typical table of contents like the 
one at the beginning of this guide. 

TOC as left-to-right menu in an HTML5 "Top Nav" target TOC as top-to-bottom menu in an HTML5 "Side Nav" target
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TOC in a print target

Cross References & Hyperlinks
Cross references are used to link to other topics, and hyperlinks are used to link to other 
types of documents (such a PDFs) and websites. 

You can setup cross references to use different formatting in print targets or even to 
include page numbers. For example, a cross reference might be formatted as "Overview 
" (underlined blue text) in online targets and "See Overview on page 11" in print targets 
(italicized black text with a page number). 

Drop-down Links
Drop-down links can be used to show and hide content when the user clicks a link. In 
the following example, the topic's introduction is initially hidden behind a drop-down link 
labeled “Overview" (left screen shot). Clicking the Overview link displays the drop-down 
text (right screen shot). 
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Creating a TOC Book or Page
TOC books are used to group topics, like chapters in a book. TOC pages normally link to 
topics. However, TOC pages and books can link to:

 n Topics
 n Files
 n URLs
 n Browse sequences
 n Other TOCs (for merging TOCs)
 n Other Flare projects (for merging projects)

Let’s create a TOC book and link it to a topic. 
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To create a TOC book: Class project notes

1 Open a TOC.

 

Open the TOC TOC.

2 Click  in the toolbar.
—OR—
Press Ctrl+F8.

A new book appears in the TOC Editor.

 

 

3 Right-click the new TOC book and select Properties.

 

 

4 Type a Label for the book.
—OR—
Insert a variable:

 n Click .

Insert the LinkedHeader variable in the System 
variable set.
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 n Select the System variable set.
 n Select the LinkedHeader, LinkedFile, or LinkedTitle variable.
 n Click OK.

 

5 Click Select Link.

The Select File dialog box appears.

 

 

6
 

Select a topic.

 

Select South America in the South America folder.

7 If necessary, move the book to a new location in the TOC.

You can drag-and-drop the TOC book or use the arrows in the TOC Editor 
toolbar.

 

Move the South America book to the bottom of the 
TOC.

8 Select Save All.  
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Using Drag-and-Drop to Add Books and Pages to a TOC 
You can also create TOC books and pages by dragging and dropping folders or topics 
from the Content Explorer into the TOC. If you drag a folder from the Content Explorer 
to a TOC, Flare will create a TOC book for the folder and TOC pages for each topic in the 
book. 

Let’s drag-and-drop the South American city topics into our "South America" TOC book. 

To use drag-and-drop to add books and pages to a TOC: Class project notes

1 Open a TOC.

 

Open the TOC TOC.

2 Open the Content Explorer.

 

 

3 Drag a folder or topic to the TOC. Drag the topics in the South America folder into the 
South America TOC book and the San Franciso topic 
into the North America book.

 

4 Rename or delete any books or pages as needed. Delete the New Entry TOC page.

Creating a Cross Reference
Cross references are used to link to other topics in a project. 

Let’s create a cross reference.

To create a cross reference to a topic: Class project notes

1 Open the topic that will contain the cross reference.

 

Open the North America topic in the North America 
folder.
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2 Position your cursor where you want to add the cross reference. Add a new bulleted list item after New York and 
position the cursor on the line.

 

3 Click   in the XML Editor toolbar.
—OR—
Select Insert > Cross Reference.
—OR—
Press Ctrl+Shift+R.

The Insert Cross Reference dialog box appears.

 

 

4 In the Link to section, select the type of link you want to create. Select Topic in Project.
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5 Select a topic.

 

Select the San Francisco topic. 

6 In the Alternative Text field, type a description of the link. 

Alternative text is recommended by accessibility guidelines such as the 
US Government’s Section 508 and the W3C’s Web Content Accessibility 
Guidelines (WCAG).

 

Type Link to the San Francisco topic.

7 Click OK.

The cross reference is added to the topic. 

 

Creating a Hyperlink
Let’s create a hyperlink to a website. 

To create a hyperlink to a website: Class project notes

1 Open the topic that will contain the link.

 

Open the Sydney topic in the Oceania folder.

 

2 Select the text that you want to use as the link.

 

 

Select sydney.com.

3 Click  in the XML Editor toolbar.
—OR—
Select Insert > Hyperlink.
—OR—
Press Ctrl+K.

The Insert Hyperlink dialog box appears.
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4 In the Link to section, select Website.

 

 

5 Type a website address.

 

Type http://www.sydney.com.

6 In the Alternative Text field, type a description of the link. 

Alternative text is recommended by the US Government’s Section 508 
and the W3C’s Web Content Accessibility Guidelines (WCAG).

 

Type Link to sydney.com.

7 If needed, select a Target Frame.

Links to websites often appear in a new window.

 

Select New Window/Tab.

 

8 Click OK.

The hyperlink is added to the topic.
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Creating a Drop-down Link
Let’s add a drop-down link to a topic.

To create a drop-down link: Class project notes

1 Open the topic that will contain the drop-down link.

 

Open the melbourne topic in the Oceania  folder.

 

2 Type and select the drop-down link and drop-down text.

 

Select the following:

Athletes

 n Ron Barassi
 n Kyrie Irving
 n Anthony Koutoufides
 n Mark Philippoussis

 

3 Select Insert > Drop-Down Text.

The  drop-down icon appears to the left of the drop-down link.

 

d
o

n
o
t

c
o
p
y



Linking Content MadCap Flare Introductory Training Guide
created with MadCap Flare

70

Learning More

The Flare help contains numerous useful topics about linking content:

Step 2: Adding Content and Features

 n Tables of Contents
 n Links > Cross-References 
 n Links > Drop-Downs
 n Links > Text Hyperlinks

 

Flare Intermediate Training
In addition to the topics covered in this class, the Flare Intermediate class 
includes the following topics:

 n Using multiple TOCs in a project
 n Finding topics that are not in the TOC
 n Locating a topic in the Content Explorer from the TOC
 n Creating an index
 n Creating search synonyms
 n Excluding topics from the search
 n Using Google Search 
 n Using Elasticsearch
 n Creating a glossary
 n Automatically adding glossary definition popups
 n Creating bookmark links
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 n Creating a link to a PDF
 n Finding and fixing broken links
 n Testing web links
 n Creating expanding links
 n Creating toggler links
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Designing Content
What You Will Learn
In this module, you will learn how to:

 n Apply a stylesheet to all topics
 n Apply a style to content
 n Assign a table stylesheet to a table
 n Add a header and footer to a page layout
 n Add content to a template page
 n Change a skin
 n Apply a template page and skin to an online target
 n Apply a page layout to a print target
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About Design
In this module, we will discuss how to design online and print targets using styles, table 
styles, page layouts, template pages, and skins.

Styles
Styles are used to format content. For example, styles can specify the font size and 
color, background color, borders, and space above, below, or to the right or left of 
content.Styles are stored together in a stylesheet.

You can also use Inline formatting (or, "style overrides") to format content. Inline 
formatting is any formatting you add by selecting a block of content and manually 
formatting it, usually by clicking an icon on the formatting toolbar. An example of inline 
formatting is if you select a topic’s heading and make it 14pt Verdana Bold.  

You should avoid using inline formatting. It's harder to keep consistent and much 
harder to update than using styles.

Table Stylesheets
Table stylesheets are used to format tables. Table stylesheets are simply small 
stylesheets that only contain table-specific formatting. 

Page Layouts
Page layouts are used to specify the page size and margins and to add headers and 
footers in print targets. You can create multiple page layouts as many page layouts as 
you need. For example, you can create an 8.5x11" page layout for user guides and a 
smaller page layout, such as 6x9”, for quick reference guides.

Template Pages
Template pages are used to add content to some or (more likely) all of your topics 
when you build an online target. For example, you could use a template page to add a 
copyright statement to the bottom of every topic.  You can also add built-in block of 
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content (called "proxies") to your template page. For example, you can use a toolbar 
proxy to add buttons, such as a previous, next, and print button, to your topics.

Skins
Skins are used to design online targets. Flare has three HTML5 skin designs: "Top Nav," 
"Side Nav," and the older "Tripane" design. A skin can be used to specify/format:

 n The logo 
 n The menu formatting (colors and sizes)
 n The search bar's size, color, and border

Applying a Stylesheet to All Topics
You can use a primary stylesheet to apply a stylesheet to all of your topics. The primary 
stylesheet will also be applied to any new or imported topics. 

Let’s apply the Styles stylesheet to all of our topics.

To apply a stylesheet to all topics: Class project notes

1 Select Project > Project Properties.

The Project Properties dialog box appears.

 

2 Select the Defaults tab.  
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3 Select a Primary Stylesheet. Select Styles.

4 If you want to be able to apply a different stylesheet to some topics in 
your project, select Allow local stylesheets.

 

Do not select Allow local stylesheets.

5 Click OK.

The topics are associated with the stylesheet. New and imported topics 
will also be automatically associated with the primary stylesheet.

 

Applying a Style to Content
Let’s open a topic and apply a style to a paragraph.

To apply a style: Class project notes

1 Open a topic.

 

Open the New York topic in the North America folder.

 

2 Select or click inside the content to which you want to apply the style.

 

Click inside the "Boroughs" paragraph.

3 Select Home > Style Window.
—OR—
Press F12.

 

The Styles window appears.

 

 

4 Click a style in the list.

The style is applied to the selected content.

Click h2.
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TIP   You can pin your most commonly-used styles to the top of the list. Just hover 
over the style's name and click the  icon.

Applying a Table Stylesheet to a Table
Let's apply our table stylesheet to a table. 

To apply a table stylesheet to a table: Class project notes

1 Open the topic where you want to apply the table stylesheet.

 

Open the Toronto topic.

2 Click inside the table.

 

 

3 Select Table > Table Properties.

The Table Properties dialog box appears.
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4 Select a Table Style and click OK. Select TableStyle.

TIP   If your table’s formatting does not change when you assign a table style sheet, 
it might include inline formatting. To remove inline formatting from  a table, 
right-click inside the table and select Table > Reset Local Cell Formatting.

Adding a Footer to a Page Layout
Page layouts are used to format print targets. For example, a page layout specifies the 
page size and margins and the content in the header and footer.

Let’s add the page number and page count variables to the page layout's footer.

To add content to a page layout's footer: Class project notes

1 Open a page layout.  

 

Open the PageLayout page layout.

2 Right-click the footer frame and select Edit Text. 

 

 

3 Select whether you want to use a template.

 

Click Yes.

4 Select a template.

 

Select Page n of N.flsnp.

5 Click OK.

The Frame Contents pane appears.

 

 

6 Modify the footer as needed.

 
Click  to center the footer.

7 Save and close the footer.  
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Selecting a Page Layout in a Target
You can set a print target to use any page layout. 

Let’s set our PDF target to use our PageLayout page layout. Then, we can build and 
view our target.

To select a page layout in a target: Class project notes

1 On the Project Organizer, open the Targets folder and double-click a 
target.  

 

Double click the PDF target.

2 Select the General tab. 

 

 

3 Select a Primary Page Layout.  

 

Select the PageLayout page layout.

4 Click Save All.  

5 Click Build.

 

 

6 When prompted, click Yes to view the output.  

Adding Content to a Template Page
In a template page, the "topic body" proxy represents the content in your topics. If you 
add content above the topic body proxy, the content will display above the topic's 
content in the online output. If you add content below the topic body proxy in the 
template page, the content will display below the topic's content in the online output. 
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TIP   To see the proxies in the XML Editor, you need to have Show Markers 
selected.

Let’s type add a copyright statement to the bottom of the template page.

To add content to a template page: Class project notes

1 Open a template page. Open the TemplatePage template page.

2 Position your cursor where you want to add content.

 

Click on the blank line at the bottom of the template 
page.

3 Type or insert your content. Type the following:

Copyright 2025, MadTravel, Inc.

Selecting a Template Page in a Target
You can set an online target to use any template page. If you do not select a template 
page, the target will not use one. 

Let's set our HTML5 target to use our template page. Then, we can build and view our 
HTML5 target.

To select a template page in a target: Class project notes

1 On the Project Organizer, open the Targets folder and double-click a 
target.  

 

Double click the HTML5 target.

2 Select the Advanced tab. 

 

 

3 Select a Template Page.  

 

Select the TemplatePage template page.

4 Click Save All.  
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5 Click Build.

 

 

6 When prompted, click Yes to view the output. 

Look at the header and footer of your topics.

 

Changing a Skin
Each skin design type (top nav, side nav, and tripane) has slightly different settings that 
you can change, but they are all setup the same way.

"Top Nav" skin design "Side Nav" skin design

Let's change our TopNav skin's logo.

To setup a skin: Class project notes

1 Open a skin. 

The Skin Editor appears.

Open the TopNav skin. Skins are stored in the Project 
Organizer in the Skins folder. 
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2 Select a Pane Position. 

 

Select Right.

3 If you want to use Pulse in your target, select the Community tab and set 
the options.

 

 

4 Select the Styles tab.

The Styles tab appears.
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5 For any item you want to change:

 n Select a style group.
 n Select a property.
 n Select a new value.

 

 n Open the Header style group.
 n Open the Logo style group.
 n Open the Background style group.

 n For Image, click .
 n Locate c:\flare intro training\files\logo.png.
 n Click Open.

Selecting a Skin in a Target
You can set an online target to use any skin. Let’s set our HTML5 target to use the 
TopNav skin.

To apply a skin to a target: Class project notes

1 Select the Skin tab.

 

 

2 Select a Skin.  Select the TopNav skin.
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Learning More

Flare Help
The Flare help contains numerous useful topics about design:

Step 3: Designing

 n Styles and Stylesheets 
 n Page Layouts
 n Template Pages
 n Skins 

 

Flare Intermediate Training
In addition to the topics covered in this class, the Flare Intermediate class 
includes the following topics:

 n Creating style classes
 n Modifying styles
 n Modifying table stylesheets
 n Advanced page layout design
 n Using template page proxies
 n Setting page sizes and margins
 n TopNav, SideNav, and Tripane skin design options
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Single Sourcing
What You Will Learn
In this module, you will learn how to:

 n Create a variable
 n Insert a variable
 n Create a snippet 
 n Insert a snippet
 n Create a condition tag
 n Apply a condition tag to content
 n Apply a condition tag to a file or folder
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About Single Sourcing
“Single sourcing” is a content development technique where content is stored in one 
location and reused rather than duplicated and maintained in multiple locations. In 
Flare, we can build multiple outputs ("called targets") that include or exclude any 
combination of our topics in any order. We can also reuse content, such as a note, table, 
or procedure, in multiple topics.

Variables 
Variables are pre-set terms that you can use over and over. For example, you can create 
a variable for a phone number and use the phone number variable in multiple topics. If 
you need to change the phone number, you only need to change the variable and it's 
updated automatically wherever the variable has been used. 

Snippets
Snippets are similar to variables, but they can include any type of content. For example, 
a snippet might contain a table that you need to include in multiple topics.  

Condition Tags
Condition tags are used to exclude content when you build a target. You can apply a 
condition tag to anything in Flare, from a single character to a paragraph, link, image, 
video, variable, or snippet, a topic, or any other file or folder in your project. After you 
apply condition tags to your content, you can setup your targets to include or exclude 
the tagged content.

Here are some examples of how you could use condition tags in a Flare project:

 n If you build online and print targets, there may be some online-specific phrases 
like "Click here for more info" that don’t make sense in print.  Or, you might have 
print-specific content that you don't need in an online target. For example, some 
Flare users don't include screenshots in their online targets. With condition tags, 
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you can tag online- and print-specific content and exclude it when needed. 

 n If you are documenting a modular application and your customers can buy 
different configurations, you can use condition tags to exclude content about the 
modules they didn't purchase. 

Creating a Variable
If you use the same text in multiple topics, you can use a variable rather than typing the 
text each time. That way, you can easily update it if the text changes.  

Let’s create a variable for our company name. 

To create a variable: Class project notes

1 Open the Project Organizer.

 

 

2 Open the Variables folder.

 

 

3 Double-click a variable set.

The Variable Set Editor window appears.

 

Double-click the Variables variable set.

4 Click  in the Variable Set Editor toolbar.

 

 

5 Type a name for the variable.

 

Type CompanyName.

6 Type a definition for the variable. Type MadTravel.
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Inserting a Variable 
Now that we’ve created our variable, we can use it in our project. Variables can be used 
almost anywhere in Flare, including in topics, snippets, template pages, and page 
layouts.

Let’s insert the CompanyName variable into a topic. 

To insert a variable into a topic: Class project notes

1 Open a topic.

 

Open the Home topic.

 

2 Place your cursor where you want to add the variable.

 

Delete MadTravel.

 

3 Select Insert > Variable.

The Variables dialog box appears.

 

 

4 Select a variable set. Select Variables.
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5 Select a variable.

TIP   You can pin your most commonly-used variables to the top 
of the list. Just hover over the variables' name in the 
Recently Used Variables list and click 

Select CompanyName.

6 Click OK.

The variable appears in the topic.

 

TIP   If you enable Auto Suggestion, Flare will prompt you to insert a variable when 
you start typing its definition. To enable Auto Suggestion, select Tools > 
Options and select the Auto Suggestion tab.

Creating a Snippet
A snippet can contain as much content as you need, from one paragraph to a large 
table with images.

Let’s create a snippet of the most populous cities in the Americas.

To create a snippet: Class project notes

1 Select File > New.

The Add File dialog appears.
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2 In the File Type section, select Snippet.

 

 

3 Select a Source.

 

Select Snippet.flsnp.

4 Select a Folder.

 

Select Resources/Snippets.

5 In the File Name field, delete the name “NewTopic” and type a new name 
for the topic.

 

Type MostPopulousCities.

6 Click Add.
The snippet opens as a new tab in the XML Editor. 
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7 Add content to the snippet.

 

Type the following: 

The most populous cities in the Americas are:

1. São Paulo

2. Lima

3. Mexico City

4. New York

5. Bogotá

 

8 Save the snippet.  

Inserting a Snippet
Let’s insert our snippet into a topic. 

To insert a snippet into a topic: Class project notes

1 Open a topic.

 

Open the Lima topic in the South America folder.

 

2 Position the cursor where you want to add the snippet.

 

Delete the list of most populous cities.

 

3 Select Insert > Snippet.

The Insert Snippet Link dialog box appears.
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4 Select a snippet.

A preview of the snippet appears.

TIP   You can pin your most commonly-used snippets to the top 
of the list. Just hover over the snippet's name in the Recently 
Used Snippets list and click .

 

Select MostPopulousCities.

5 Click OK.

The snippet is added to the topic.

 

TIP   If you enable Auto Suggestion, Flare will prompt you to insert a snippet when 
you start typing its content. To enable Auto Suggestion, select File > Options 
and select the Auto Suggestion tab.

Creating a Condition Tag
Let’s create a condition tag for draft content. We can then exclude draft content when 
we build a target. 
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To create a condition tag: Class project notes

1 Open the Conditional Text folder in the Project Organizer.

 

 

2 Double-click a condition tag set.

The Condition TagSet Editor appears.

 

Open the Conditions condition tag set.

3 Click  in the ConditionTagSet Editor toolbar.

A new tag appears. 

 

 

4 Double-click the new tag’s name.

 

 

5 Type a new name for the tag and press Enter.

 

Type Draft.

6 Select a color.

 

Select dark red.

7 Click Save.  

Applying a Condition Tag to a File or Folder
Let's apply the Draft condition tag to a topic. 

To apply a condition tag to a topic: Class project notes

1 Open the Content Explorer.

 

 

2 Select the file or folder to be tagged.

 

Select the Tokyo topic.
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3 Click   in the Content Explorer toolbar.

The Properties dialog box appears.

 

 

4 Select the Conditional Text tab.

The Conditional Text tab appears.

 

5 
 

Select a condition tag set. 

 

 

6 Select a tag’s checkbox.

 

Select the Draft tag.

7 Click OK.

The tag is applied and the file or folder’s box is filled with the tag’s color.

 

NOTE    If you don’t see the condition tag’s color,  click the Hide/Show Conditional 
Indicators icon in the Content Explorer toolbar.

Applying a Condition Tag to Content
Let's apply the Draft tag to content inside a topic.
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To apply a condition tag to content: Class project notes

1 Open a topic.

 

Open the Asia topic in the Asia folder.

 

2 Select the content to be tagged.

You can apply a tag to any content, including a character, word, 
paragraph, bookmark, or image.

 

Select the "Tokyo" bullet.

3 
 

Select Home > Conditions. 

The Condition Tags dialog box appears.

 

 

4 
 

Select a condition tag set. 

 

 

5 Select a condition tag’s checkbox.

 

Select the Draft checkbox.

6 Click OK.

The tag is applied. The tagged content is shaded using the tag’s color.

 

NOTE    If you don’t see the condition tag’s color, click the Hide/Show Conditional 
Indicators icon in the XML Editor toolbar.
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Learning More

Flare Help
The Flare help contains numerous useful topics about single sourcing:

Step 2: Adding Content and Features

 n Variables 

 n Snippets 

 n Conditions 

 

Flare Intermediate Training
In addition to the topics covered in this class, the Flare Intermediate class 
includes the following topics:

 n Creating variables with multiple definitions
 n Applying styles to variables
 n Creating a snippet from existing content
 n Using auto-suggestion to insert variables and snippets
 n Best practices for setting up and using condition tags
 n Advanced options for excluding content and topics
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Topics Reviews and Targets 
What You Will Learn
In this module, you will learn how to:

 n Plan topic reviews using Flare Online
 n Plan topic reviews using MadCap Contributor
 n Plan topic reviews using Word/PDF
 n Setup an HTML5 target
 n Build an HTML5 target
 n View an HTML5 target
 n Create a PDF target
 n Setup a PDF target
 n Build a PDF document
 n View a PDF document
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Flare Online Reviews
If your reviewers use Flare Online, you can upload the topics to Flare Online. Reviewers 
can then edit the topics and add annotations using Flare Online in a browser. 

There are four main advantages for using Flare Online for reviews: 

 n You can easily send one, multiple, or all topics for review

 n Reviewers do not need to install any software (Flare Online is cloud based)

 n Multiple reviewers can "share" the review topics and see each others' changes 
and comments

 n Reviewers add their changes and comments to copies of the source files, so it is 
easy to integrate their changes and comments 

Flare Online review workflow
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MadCap Contributor Reviews
If your reviewers use Contributor, you can send them the review package or copy it to 
SharePoint or a network drive. Reviewers can then edit the topics and add annotations 
using Contributor. 

There are two main advantages for using Contributor for reviews: 

 n You can easily send one, multiple, or all topics for review

 n Reviewers add their changes and comments to copies of the source files, so it is 
easy to integrate their changes and comments 

Contributor review workflow
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Word/PDF Reviews
If your reviewers want to use Word or PDF documents, you can send them a Word or 
PDF document or copy it to SharePoint or a network drive. Reviewers can then edit the 
topics and add comments/notes. 

The biggest disadvantage to using Word/PDF documents for reviews is that finding and 
integrating the reviewers' changes/comments can be very time consuming. 

Word/PDF review workflow
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About Targets
Flare produces eleven types of output: 

 n DITA
 n Eclipse Help
 n MadCap Clean XHTML
 n MadCap HTML5
 n MadCap WebHelp
 n MadCap WebHelp Plus
 n Microsoft HTML Help

 n Adobe PDF
 n EPUB
 n Microsoft Word
 n MOBI 

You can build any or all of these output types from the same project, and, as you 
learned in the last module, you can use condition tags to exclude content when you 
build a target. 

In this class, we will focus on the two most popular output types: HTML5 and PDF.

HTML5
HTML5 is the recommended online target type. The HTML5 target type uses the 
HTML5 specification as developed by the Web Hypertext Application Technology 
Working Group (WHATWG) and the World Wide Web Consortium (W3C). Users can 
open an HTML5 target in any browser on any type of device, including phones, tablets, 
and computers.

PDF
PDF ("Portable Document Format") is an open standard format for electronic 
documents that was invented by Adobe. Although PDFs are often viewed online, PDF is 
considered a print-based format.
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Setting Up an HTML5 Target
You can use the Target Editor to select a TOC, skin, and template page to use for an 
HTML5 target. You can also select the condition tags you want to exclude. 

Let’s make some changes to our HTML5 target.

To setup an HTML5 target: Class project notes

1 Open an HTML5 target.

 

Open HTML5.

2 For Startup Topic, click  , select a topic, and click Open.

The startup topic is the first topic the user will see when they open the 
HTML5 output.

Select Home.
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3 Select a Primary TOC.

 

Select TOC.

4 Select the Skin tab.

 

 

5 Select a Skin.

 

Select TopNav.

6 Select the Conditional Text tab.

 

 

7 Select the condition tags that you would like to exclude. 

By default, all content is included.

 

Exclude Conditions.Draft.

8 Select the Advanced tab.
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9 Select a Template Page.

 

Select TemplatePage.

10 Click Save.  

Building an HTML5 Target
Let’s build our HTML5 target and see how it looks. 

To build an HTML5 target: Class project notes

1 On the Project Organizer, right-click an HTML5 target.

 

Right-click the HTML5 target.

2 Select Build.
If you made any changes to the target, Flare will prompt you to save the 
changes. Click Yes.

The Builds pane appears.

 

 

3 When the build is complete, double-click the target in the Build pane to 
view the output.

NOTE  You can highlight a target in the Builds pane and click View 
Output to open it in a different browser.

 

Setting Up a PDF Target
You can use the Target Editor to select a TOC and page layout to use for a PDF target. 
You can also select the condition tags you want to exclude. 

Let’s make some changes to our PDF target.
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To setup a PDF target: Class project notes

1 Open a  target.

 

Open PDF.

2 Select a Primary TOC.

 

Select TOC.

3 Select a Primary Page Layout.

 

Select PageLayout.

4 Type an Output File name. 

 

Type Cities.pdf.

5 Select the Conditional Text tab.

 

 

6 Select the condition tags that you would like to exclude. 

 

Exclude Conditions.Draft.

7 Select the Advanced tab.
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8 If you want to automatically include a table of contents (TOC), index, and 
glossary in your target, enable the following options:

 n Generate TOC Proxy
 n Generate Index Proxy
 n Generate Glossary Proxy

 

Select Generate TOC Proxy.

9 Select the PDF Options tab.

 

 

10 Select whether you want to Generate tagged document for PDF/UA.

Tagged PDFs include additional information to improve accessibility 
when used with screen readers and magnifiers.

 

 Select Generate tagged document for PDF/UA..

11 Click Save.  

Building a PDF Target
Let’s build our PDF target and see how it looks now that we’ve changed the target 
settings. 

To build a PDF target: Class project notes

1 On the Project Organizer, right-click the target.

 

Right-click PDF.

2 Select Build.

 

 

3 If you made any changes to the target, Flare will prompt you to save the 
changes. Click Yes.

The Builds pane appears.
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4 When the build is complete, double-click the target in the Builds pane to 
view the output.
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Learning More

Flare Help
The Flare help contains numerous useful topics about reviews and targets:

Project Management > Reviews and Collaboration

 n Flare Online Review Process
 n Reviews and Contributions with MadCap Contributor

Step 5: Building and Publishing Output

 n  Adding Targets 
 n Editing Target Settings  
 n Building and Publishing a Single Target
 n Building and Publishing Multiple Targets
 n Publishing Destinations

 

Flare Intermediate Training
In addition to the topics covered in this class, the Flare Intermediate class 
includes the following topics:

 n Tracking changes
 n Accepting or rejecting tracked changes
 n Adding annotations
 n Creating Word targets
 n Publishing targets
 n Using Flare Desktop with Flare Online
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